summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-04-26 18:16:32 +0530
committerEfraim Flashner <efraim@flashner.co.il>2022-05-09 11:14:18 +0300
commita99054795240cb7c17754816127a86d764fe76db (patch)
tree063f72ce45f6e59d02dacfd33ecd218ce2f45291
parentff1fd3b0120317adae839ca28658eddc480f130c (diff)
downloadguix-a99054795240cb7c17754816127a86d764fe76db.tar.gz
gnu: tabixpp: Use #:make-flags.
* gnu/packages/bioinformatics.scm (tabixpp)[arguments]: Do not override the
build phase. Move the required make arguments to #:make-flags. Add
build-libraries phase.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/bioinformatics.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ed4836998b..35e575d17c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14298,18 +14298,18 @@ mutations from scRNA-Seq data.")
    (inputs
     (list htslib zlib))
    (arguments
-    (list #:tests? #f ; There are no tests to run.
+    (list #:make-flags #~(list "HTS_HEADERS="
+                               (string-append "HTS_LIB="
+                                              (search-input-file %build-inputs
+                                                                 "/lib/libhts.a"))
+                               "INCLUDES=")
+          #:tests? #f ; There are no tests to run.
           #:phases
           #~(modify-phases %standard-phases
               (delete 'configure) ; There is no configure phase.
-              ;; The build phase needs overriding the location of htslib.
-              (replace 'build
+              ;; Build shared and static libraries.
+              (add-after 'build 'build-libraries
                 (lambda* (#:key inputs #:allow-other-keys)
-                  (invoke "make"
-                          (string-append "HTS_LIB=" (search-input-file inputs "/lib/libhts.a"))
-                          (string-append "INCLUDES= -I" (search-input-directory inputs "/include/htslib"))
-                          "HTS_HEADERS=" ; No need to check for headers here.
-                          (string-append "LIBPATH=-L. -L" (search-input-directory inputs "/include")))
                   (invoke "g++" "-shared" "-o" "libtabixpp.so" "tabix.o" "-lhts")
                   (invoke "ar" "rcs" "libtabixpp.a" "tabix.o")))
               (replace 'install