summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-07 10:24:41 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-08 19:32:44 +0200
commitb212cdaedbaa683307aacd59d9988c441f55ad71 (patch)
treefa7bb49044ae7878bf98563edd185623619b7386
parentbaed82efa7d3ad714d40e38c59808c1e82e708d7 (diff)
downloadguix-b212cdaedbaa683307aacd59d9988c441f55ad71.tar.gz
gnu: sbcl-puri: Remove Make reference from closure.
* gnu/packages/lisp-xyz.scm (sbcl-puri)[source]: Delete the 'debian' folder.

This takes the closure size from 209 MiB down to 151 MiB.
-rw-r--r--gnu/packages/lisp-xyz.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 63ff71569b..5a31097f92 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2706,7 +2706,13 @@ utilities that make it even easier to manipulate text in Common Lisp.  It has
                (commit commit)))
          (file-name (git-file-name "puri" version))
          (sha256
-          (base32 "0gq2rsr0aihs0z20v4zqvmdl4szq53b52rh97pvnmwrlbn4mapmd"))))
+          (base32 "0gq2rsr0aihs0z20v4zqvmdl4szq53b52rh97pvnmwrlbn4mapmd"))
+         (modules '((guix build utils)))
+         (snippet
+          ;; The useless bundled debian folder drags `make' into the closure.
+          `(begin
+             (delete-file-recursively "debian")
+             #t))))
       (build-system asdf-build-system/sbcl)
       (native-inputs
        (list sbcl-ptester))