summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-10-24 13:26:49 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-10-24 13:28:05 +0000
commitb3ac826e18f5a90849bceac791a8b886f4397464 (patch)
treeccd90c2f899850d251501b977722c27d166286c2
parent78ea1ce7d557023a4a59d2979b563593621332bd (diff)
downloadguix-b3ac826e18f5a90849bceac791a8b886f4397464.tar.gz
gnu: blender: Use older TBB and update header variables.
* gnu/packages/graphics.scm (blender)[inputs]: Replace tbb with tbb-2020.
[arguments]: Don't set CPATH; set C_INCLUDE_PATH and CPLUS_INCLUDE_PATH instead.
-rw-r--r--gnu/packages/graphics.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ca18907aae..6b6cc85afe 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -552,13 +552,19 @@ typically encountered in feature film production.")
                #t))
            (add-after 'set-paths 'add-ilmbase-include-path
              (lambda* (#:key inputs #:allow-other-keys)
-               ;; OpenEXR propagates ilmbase, but its include files do not appear
-               ;; in the CPATH, so we need to add "$ilmbase/include/OpenEXR/" to
-               ;; the CPATH to satisfy the dependency on "half.h".
-               (setenv "CPATH"
-                       (string-append
-                        (search-input-directory inputs "include/OpenEXR")
-                        ":" (or (getenv "CPATH") "")))))))))
+               ;; OpenEXR propagates ilmbase, but its include files do not
+               ;; appear in the C_INCLUDE_PATH, so we need to add
+               ;; "$ilmbase/include/OpenEXR/" to the C_INCLUDE_PATH to satisfy
+               ;; the dependency on "half.h" and "Iex.h".
+               (let ((headers (string-append
+                               (assoc-ref inputs "ilmbase")
+                               "/include/OpenEXR")))
+                 (setenv "C_INCLUDE_PATH"
+                         (string-append headers ":"
+                                        (or (getenv "C_INCLUDE_PATH") "")))
+                 (setenv "CPLUS_INCLUDE_PATH"
+                         (string-append headers ":"
+                                        (or (getenv "CPLUS_INCLUDE_PATH") ""))))))))))
     (inputs
      `(("boost" ,boost)
        ("jemalloc" ,jemalloc)
@@ -585,7 +591,7 @@ typically encountered in feature film production.")
        ("python" ,python)
        ("python-numpy" ,python-numpy)
        ("openvdb" ,openvdb)
-       ("tbb" ,tbb)
+       ("tbb" ,tbb-2020)
        ("zlib" ,zlib)
        ("embree" ,embree)))
     (home-page "https://blender.org/")