summary refs log tree commit diff
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-07-03 17:37:35 +0800
committerLudovic Courtès <ludo@gnu.org>2022-07-04 12:29:05 +0200
commitb49c2e558daee907c47c451b6ded316153d9c702 (patch)
treeed5d39d8c7cbe208a4adfa6df8c026382b4a4e7d
parentda6ea4ab884dfb69557c688bf210aa948e1a1984 (diff)
downloadguix-b49c2e558daee907c47c451b6ded316153d9c702.tar.gz
gnu: Add fmt-for-solidity.
* gnu/packages/pretty-print.scm (fmt-for-solidity): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/pretty-print.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 4ee46b4e89..9745a9ba10 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2022 Zhu Zihao  <all_but_last@163.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -187,6 +188,19 @@ to @code{IOStreams}.")
     ;; The library is bsd-2, but documentation and tests include other licenses.
     (license (list bsd-2 bsd-3 psfl))))
 
+(define-public fmt-for-solidity
+  (package
+    (inherit fmt)
+    (name "fmt-for-solidity")
+    (version "8.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
+                           version "/fmt-" version ".zip"))
+       (sha256
+        (base32 "1gqmsk4r93x65cqs8w7zhfiv70w5fv8279nrblggqm4mmdpaa9x6"))))))
+
 (define-public fmt-7
   (package (inherit fmt)
     (version "7.1.3")