summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@posteo.net>2022-05-16 23:34:19 -0500
committerEric Bavier <bavier@posteo.net>2022-06-08 23:27:47 -0500
commitb68c87f86a09d4d10f2f614ee92bfca570e42f4b (patch)
tree31c7400923ce57e0f17b22db831ba806e1077714
parente14918f402d6f61814d36463255a2be24ebbb352 (diff)
downloadguix-b68c87f86a09d4d10f2f614ee92bfca570e42f4b.tar.gz
gnu: Add PyGLM.
* gnu/packages/python-science.scm (python-pyglm): New variable.
-rw-r--r--gnu/packages/python-science.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 855fe9a72c..0684826a6c 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -19,6 +19,7 @@
 ;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2022 Wiktor Żelazny <wzelazny@vurv.cz>
+;;; Copyright © 2022 Eric Bavier <bavier@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -858,6 +859,32 @@ and more
 @end itemize")
     (license license:gpl3)))
 
+(define-public python-pyglm
+  (package
+    (name "python-pyglm")
+    (version "2.5.7")
+    (source
+     (origin
+       ;; Test files are not included in the archive in pypi.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Zuzu-Typ/PyGLM")
+             (commit version)
+             ;; Checkout the bundled `glm` submodule.  PyGLM uses the
+             ;; currently unreleased GLM_EXT_matrix_integer feature.  Can
+             ;; maybe unbundle once glm@0.9.9.9 is released.
+             (recursive? #t)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "08v0cgkwsf8rxscx5g9c5p1dy38rvak2fy3q6hg985if1nj6d9ks"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/Zuzu-Typ/PyGLM")
+    (synopsis "OpenGL Mathematics library for Python")
+    (description "PyGLM is a Python extension library which brings the OpenGL
+Mathematics (GLM) library to Python.")
+    (license license:zlib)))
+
 (define-public python-distributed
   (package
     (name "python-distributed")