summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-06 23:05:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-06 23:05:05 -0400
commitbdc0c20cab77a25d260345a79ee0611c7e06e8ce (patch)
tree3c9103b98f1c6b62a0994742219d3046f64fdf58
parentfb09818277d602e5f5b1c6ecde0b1944080291b7 (diff)
downloadguix-bdc0c20cab77a25d260345a79ee0611c7e06e8ce.tar.gz
gnu: imposm3: Fix build.
* gnu/packages/geo.scm (imposm3)[arguments]: Adapt unpack-path for the new
unpack phase.
[phases]: Remove the "rename-import" phase, now obsolete.
-rw-r--r--gnu/packages/geo.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 0b95fbe613..c8d149a7a2 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -713,14 +713,9 @@ delivered to any client.")
     (build-system go-build-system)
     (arguments
      `(#:import-path "github.com/omniscale/imposm3/cmd/imposm"
-       #:unpack-path "github.com/omniscale"
+       #:unpack-path "github.com/omniscale/imposm3"
        #:phases
        (modify-phases %standard-phases
-         (add-before 'build 'rename-import
-           (lambda _
-             (rename-file (string-append "src/github.com/omniscale/imposm3-" ,version)
-                          "src/github.com/omniscale/imposm3")
-             #t))
          (add-before 'build 'set-version
            (lambda _
              (substitute* "src/github.com/omniscale/imposm3/version.go"