summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 23:31:40 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:15 +0200
commitc70f00e203e913226c08c5bba4bc2b9c57571117 (patch)
treecc87a05652a6042d113aaf493f9fad5b716ba116
parent59a50276043d2054eb7f74a64a4e5cc8b8f1157e (diff)
downloadguix-c70f00e203e913226c08c5bba4bc2b9c57571117.tar.gz
gnu: ghc-blaze-markup: Update to 0.8.2.1.
* gnu/packages/haskell.scm (ghc-blaze-markup): Update to 0.8.2.1.
[arguments]: Add a phase that patches the Cabal file to allow newer
versions of tasty.
-rw-r--r--gnu/packages/haskell.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d621c00840..92703ee668 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4284,7 +4284,7 @@ interoperate with code that uses the new implementation.")
 (define-public ghc-blaze-markup
   (package
     (name "ghc-blaze-markup")
-    (version "0.8.2.0")
+    (version "0.8.2.1")
     (source
      (origin
        (method url-fetch)
@@ -4293,8 +4293,16 @@ interoperate with code that uses the new implementation.")
                            version ".tar.gz"))
        (sha256
         (base32
-         "0m3h3ryxj5r74mv5g5dnfq5jbbwmvkl7ray18vi20d5vd93sydj4"))))
+         "0ih1c3qahkdgzbqihdhny5s313l2m66fbb88w8jbx7yz56y7rawh"))))
     (build-system haskell-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'update-constraints
+           (lambda _
+             (substitute* "blaze-markup.cabal"
+               (("tasty            >= 1\\.0  && < 1\\.1")
+                "tasty            >= 1.0  && < 1.2")))))))
     (inputs
      `(("ghc-blaze-builder" ,ghc-blaze-builder)
        ("ghc-text" ,ghc-text)))