summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-22 07:38:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-22 08:57:37 +0100
commitc8b535aa6962501e945acdf4acc7dcd9d73ce28b (patch)
tree2791c780a0f8d32a30e68764f4506642b115b798
parentda531f9b4cafb3dea02ca236d10695a1ff558ebc (diff)
downloadguix-c8b535aa6962501e945acdf4acc7dcd9d73ce28b.tar.gz
gnu: python-prawcore: Update to 7.5.0.
* gnu/packages/python-web.scm (python-prawcore): Update to 7.5.0.
[arguments]: Disable two broken tests.
-rw-r--r--gnu/packages/python-web.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 54ac98c483..5c9d57005b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -125,13 +125,13 @@
 (define-public python-praw
   (package
     (name "python-praw")
-    (version "7.2.0")
+    (version "7.5.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "praw" version))
        (sha256
-        (base32 "0ll1a0n8xs8gykizdsfrw63jp6bc39ab0pk3yzwcak96fyxh0ij3"))))
+        (base32 "1nqcwz8r8xp4rfpy2i11x2fjga8fmmf6zw94xjk1h1yxgn1gq6zr"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -139,16 +139,18 @@
          (add-after 'unpack 'disable-failing-tests
            (lambda _
              (with-directory-excursion "tests"
-               ;; Require networking.
+               ;; Integration tests depend on files that are not included.
                (for-each delete-file-recursively
                          '("integration/models" "unit/models"))
-               ;; https://github.com/praw-dev/praw/issues/1699
-               ;; #issuecomment-795336704
+               ;; The configuration file does not seem to exist.
                (delete-file "unit/test_config.py"))))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (invoke "pytest")))))))
+               (invoke "pytest" "-k"
+                       ;; These tests depend on test files that don't exist.
+                       (string-append "not test_bad_request_without_json_text_plain_response"
+                                      " and not test_bad_request_without_json_text_html_response"))))))))
     (native-inputs
      `(("python-betamax" ,python-betamax)
        ("python-betamax-matchers" ,python-betamax-matchers)