summary refs log tree commit diff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-02-25 14:46:08 +0000
committerMarius Bakke <mbakke@fastmail.com>2020-03-29 22:34:47 +0200
commitcedd56f262f3fb43763e66b590f048d6be5b1925 (patch)
treeb61a06afd8037d1a58b0cf0ca2c94949da33124a
parent99f3fdd182a696516303d26ed19de28a514269d4 (diff)
downloadguix-cedd56f262f3fb43763e66b590f048d6be5b1925.tar.gz
gnu: Add vl1-emulator.
* gnu/packages/music.scm (vl1-emulator): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/music.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30e6dc48c..8989f71937 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5293,3 +5293,42 @@ as JACK standalone applications.")
 automation that comes as an LV2 plugin bundle with a custom UI.")
     (home-page "https://git.zrythm.org/cgit/ZLFO/")
     (license license:agpl3+)))
+
+(define-public vl1-emulator
+  (package
+    (name "vl1-emulator")
+    (version "1.1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/linuxmao-org/VL1-emulator.git")
+             (commit (string-append "v" version))
+             ;; bundles a specific commit of the DISTRHO plugin framework
+             (recursive? #t)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1npc86vqma8gk1hawa0lii0r2xmnv846plyl1ci3bdswyrdk5chm"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ;no check target
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             "CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))         ;no configure target
+    (inputs
+     `(("cairo" ,cairo)
+       ("jack" ,jack-1)
+       ("mesa" ,mesa)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/linuxmao-org/VL1-emulator")
+    (synopsis "Emulator of Casio VL-Tone VL1")
+    (description "The VL1-Emulator is an emulator of Casio VL-Tone VL1, 
+based on source code by PolyValens, offered as an LV2 plugin and a 
+standalone JACK application.")
+    ;; Expat or CC0
+    (license (list license:expat license:cc0))))