summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 03:05:13 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-02 03:05:58 +0200
commitd20720755eedd30c08743e66621e2ec8c023d326 (patch)
tree4b2dbae357045ab5eba691dfd816f7dd4f2ac1c2
parent1b313032943db85e0d6b8550d02671036f3a5d36 (diff)
downloadguix-d20720755eedd30c08743e66621e2ec8c023d326.tar.gz
gnu: boinc-client, boinc-server: Update to 7.16.17.
* gnu/packages/distributed.scm (boinc-client): Update to 7.16.17.
(boinc-server): Run the test suite.
-rw-r--r--gnu/packages/distributed.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/distributed.scm b/gnu/packages/distributed.scm
index e6dab08f23..868fc589a6 100644
--- a/gnu/packages/distributed.scm
+++ b/gnu/packages/distributed.scm
@@ -44,7 +44,7 @@
 (define-public boinc-client
   (package
     (name "boinc-client")
-    (version "7.16.6")
+    (version "7.16.17")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -55,7 +55,7 @@
               (file-name (git-file-name "boinc" version))
               (sha256
                (base32
-                "00xpzxxnki9hsf2vg9p67dk9ilw9ychpgm09fp3c41zyylb33ml5"))))
+                "1p8y3mnf5yfhavhqxwf9v68prg1601h8q1pllm5z89zh661di3mj"))))
     (build-system gnu-build-system)
     (arguments '(#:configure-flags '("--disable-server")))
     (inputs `(("openssl" ,openssl)
@@ -82,13 +82,12 @@ resources).  It supports virtualized, parallel, and GPU-based applications.")
     (license (list license:lgpl3+ license:gpl3+))))
 
 (define-public boinc-server
+  ;; XXX The server and client packages duplicate many files such as /lib.
+  ;; TODO: consolidate them?
   (package (inherit boinc-client)
     (name "boinc-server")
     (arguments '(#:configure-flags '("--disable-client" "--disable-manager")
-                 #:parallel-build? #f
-                 #:tests? #f)) ; FIXME: Looks like bad test syntax in the
-                               ; source package, 2 tests fail.  Disable for
-                               ; now.
+                 #:parallel-build? #f))
     (inputs `(("openssl" ,openssl)
               ("curl" ,curl)
               ("mariadb:dev" ,mariadb "dev")