summary refs log tree commit diff
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2021-12-30 14:37:53 -0500
committerLeo Famulari <leo@famulari.name>2021-12-30 15:37:35 -0500
commitd6b519c7184bba64977f2ae89195731b2c77d34f (patch)
tree32918d453a1b79083ab0a7ff9a02637cd5a15bfb
parent2c864ca93357bce26f541f12395496da073e65a5 (diff)
downloadguix-d6b519c7184bba64977f2ae89195731b2c77d34f.tar.gz
gnu: Blender: Update to 3.0.0.
* gnu/packages/graphics.scm (blender): Update to 3.0.0.
[inputs]: Add the "lib" output of zstd. Replace tbb-2020 with tbb.

Co-authored-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/graphics.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 73db17bb17..fe35aaad2d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -409,14 +409,14 @@ typically encountered in feature film production.")
 (define-public blender
   (package
     (name "blender")
-    (version "2.93.6")
+    (version "3.0.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://download.blender.org/source/"
                                   "blender-" version ".tar.xz"))
               (sha256
                (base32
-                "19i84bh8jiamf38fj9p24q8w8fhg3hhl49940dh74h4flyfyqfg7"))))
+                "1jzirg60c2lhln78a7phbsk2ssvcdqxqb3awp895m0pqrlmz7w2h"))))
     (build-system cmake-build-system)
     (arguments
       (let ((python-version (version-major+minor (package-version python))))
@@ -498,8 +498,9 @@ typically encountered in feature film production.")
        ("python" ,python)
        ("python-numpy" ,python-numpy)
        ("openvdb" ,openvdb)
-       ("tbb" ,tbb-2020)
+       ("tbb" ,tbb)
        ("zlib" ,zlib)
+       ("zstd" ,zstd "lib")
        ("embree" ,embree)))
     (home-page "https://blender.org/")
     (synopsis "3D graphics creation suite")