summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-09 00:56:37 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 21:27:25 +0100
commitde92ab21c162e69bd15b7215ade61bc47603c8bc (patch)
tree2ead72cbee7716c83913f65accf377a956e363be
parent94295903939471314e5c89f4eff73bee28b9def6 (diff)
downloadguix-de92ab21c162e69bd15b7215ade61bc47603c8bc.tar.gz
gnu: python-dateutil: Update to 2.8.0.
* gnu/packages/time.scm (python-dateutil): Update to 2.8.0.
[arguments]: New field.
[native-inputs]: Add PYTHON-PYTEST.
-rw-r--r--gnu/packages/time.scm20
1 files changed, 17 insertions, 3 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 948d2b995c..e67960db0d 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -145,17 +145,31 @@ Pendulum instances.")
 (define-public python-dateutil
   (package
     (name "python-dateutil")
-    (version "2.7.3")
+    (version "2.8.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "python-dateutil" version))
        (sha256
         (base32
-         "1f7h54lg0w2ckch7592xpjkh8dg87k2br256h0iw49zn6bg02w72"))))
+         "17nsfhy4xdz1khrfxa61vd7pmvd5z0wa3zb6v4gb4kfnykv0b668"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      ;; Delete tests that depend on "freezegun" to avoid a
+                      ;; circular dependency.
+                      (delete-file "dateutil/test/test_utils.py")
+                      (delete-file "dateutil/test/test_rrule.py")
+
+                      ;; XXX: Fails to get timezone from /etc/localtime.
+                      (delete-file "dateutil/test/test_tz.py")
+
+                      (invoke "pytest" "-vv"))))))
     (native-inputs
-     `(("python-setuptools-scm" ,python-setuptools-scm)))
+     `(("python-pytest" ,python-pytest)
+       ("python-setuptools-scm" ,python-setuptools-scm)))
     (propagated-inputs
      `(("python-six" ,python-six)))
     (home-page "https://dateutil.readthedocs.io/en/stable/")