summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-07-02 21:03:54 +0100
committerLudovic Courtès <ludo@gnu.org>2022-07-08 23:58:12 +0200
commite72c1f148a473d67fa525e49caf18cf138d02e10 (patch)
tree701fccc9e49f4dcf26f1ca57179eada67a358db4
parentff6129beb5563fcff1dd57a8ee1e842b3da6b672 (diff)
downloadguix-e72c1f148a473d67fa525e49caf18cf138d02e10.tar.gz
gnu: Add python-cdflib.
* gnu/packages/astronomy.scm (python-cdflib): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/astronomy.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 82a67ce5ef..498252aaf4 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -918,6 +918,51 @@ astronomy and astrophysics.")
 to access online Astronomical data.  Each web service has its own sub-package.")
     (license license:bsd-3)))
 
+(define-public python-cdflib
+  (package
+    (name "python-cdflib")
+    (version "0.4.4")
+    (source
+     (origin
+       (method git-fetch)   ; no tests in pypi archive
+       (uri (git-reference
+             (url "https://github.com/MAVENSDC/cdflib")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1h7750xvr6qbhnl2w3bhccs3pwp3hci3624pvvxym0yjinmskjlz"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (setenv "HOME" (getcwd))
+                     (invoke "pytest" "-vv" "tests")))))))
+    (propagated-inputs
+     (list python-attrs python-numpy))
+    (native-inputs
+     (list python-astropy
+           python-hypothesis
+           python-pytest
+           python-pytest-cov
+           python-pytest-remotedata
+           python-xarray))
+    (home-page "https://github.com/MAVENSDC/cdflib")
+    (synopsis "Python library to deal with NASA's CDF astronmical data format")
+    (description "This package provides a Python CDF reader toolkit
+It provides the following functionality:
+@itemize
+@item Ability to read variables and attributes from CDF files
+@item Writes CDF version 3 files
+@item Can convert between CDF time types (EPOCH/EPOCH16/TT2000) to other common
+time formats
+@item Can convert CDF files into XArray Dataset objects and vice versa,
+attempting to maintain ISTP compliance
+@end itemize\n")
+    (license license:expat)))
+
 (define-public python-photutils
   (package
     (name "python-photutils")