summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-10-07 10:37:40 +0100
committerChristopher Baines <mail@cbaines.net>2018-10-12 08:23:15 +0100
commite9ab649e1e6400cdbf5147144903c1212cba798a (patch)
treed0dd8bf7c1e8e7186afd3e5e8b83a4fa1128d8d5
parent1c795c4fd2c0f82892c5d1683de197868ecc5214 (diff)
downloadguix-e9ab649e1e6400cdbf5147144903c1212cba798a.tar.gz
gnu: Remove duplicate ruby-concurrent package definition.
* gnu/packages/ruby.scm (ruby-concurrent): Remove one of the two definitions
for this variable.
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 0 insertions, 19 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2080944cae..2c5777fdf8 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -194,25 +194,6 @@ a focus on simplicity and productivity.")
                (("/bin/sh") (which "sh")))
              #t)))))))
 
-(define-public ruby-concurrent
-  (package
-    (name "ruby-concurrent")
-    (version "1.0.5")
-    (source (origin
-              (method url-fetch)
-              (uri (rubygems-uri "concurrent-ruby" version))
-              (sha256
-               (base32
-                "183lszf5gx84kcpb779v6a2y0mx9sssy8dgppng1z9a505nj1qcf"))))
-    (build-system ruby-build-system)
-    (arguments `(#:tests? #f)); No rakefile
-    (home-page "https://github.com/ruby-concurrency/concurrent-ruby")
-    (synopsis "Concurrency tools for Ruby")
-    (description "This gem provides concurrency tools for Ruby.  It provides
-a library of common thread-safe types and data-structures as well as abstractions
-for concurrency and communication between threads.")
-    (license license:expat)))
-
 (define-public ruby-highline
   (package
     (name "ruby-highline")