summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-22 22:36:47 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-22 23:50:55 +0100
commitf12cf46eed08c5e8cc6ffec7316ea2de262aa607 (patch)
tree8f8cea1776a1f7923e32aa69597ef4af98c0ed5a
parent021d3a32f5a2544e1111f8bbec20b75c40ad007d (diff)
downloadguix-f12cf46eed08c5e8cc6ffec7316ea2de262aa607.tar.gz
gnu: meson-wrapped: Do not propagate Python.
* gnu/packages/build-tools.scm (meson-wrapped)[propagated-inputs,
inputs]: New fields.
-rw-r--r--gnu/packages/build-tools.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 6a8a9c6f66..249d8bc45b 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -285,7 +285,12 @@ files and generates build instructions for the Ninja build system.")
                   ;; Python interpreter, so we cannot use the shell wrapper.
                   (delete 'wrap))))
     (inputs `(("ninja" ,ninja)))
+
+    ;; XXX: Python is propagated just to 'GUIX_PYTHONPATH' is set (!).
+    ;; MESON-WRAPPED below fixes that by wrapping the 'meson' executable.
+    ;; TODO: Make MESON-WRAPPED the new MESON on the next core update cycle.
     (propagated-inputs `(("python" ,python)))
+
     (home-page "https://mesonbuild.com/")
     (properties '((hidden? . #t)))
     (synopsis "Build system designed to be fast and user-friendly")
@@ -300,6 +305,9 @@ resembles Python.")
 
 (define-public meson-wrapped
   (package/inherit meson
+    (propagated-inputs '())                       ;don't propagate Python
+    (inputs (modify-inputs (package-inputs meson)
+              (prepend python-wrapper)))
     (arguments
      `(;; FIXME: Tests require many additional inputs and patching many
        ;; hard-coded file system locations in "run_unittests.py".