summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-08-07 16:11:01 +0200
committerLudovic Courtès <ludo@gnu.org>2023-08-07 16:11:44 +0200
commitf1badc9406aca4e59ab1eb823c40bd333612833e (patch)
tree47e8b9755a094cedfb2ef8f7117505478f725718
parent67d480d4a08ddbcebc4d785e0d6f2eddd3f35106 (diff)
downloadguix-f1badc9406aca4e59ab1eb823c40bd333612833e.tar.gz
gnu: praat: Honor #:tests?.
* gnu/packages/language.scm (praat)[arguments]: Check #:tests? in 'check
phase.
-rw-r--r--gnu/packages/language.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index 758fb4f336..175cdc8d5e 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -877,9 +877,10 @@ noun phrases, verb phrases, etc.).")
                             (copy-file "makefiles/makefile.defs.linux.pulse"
                                        "makefile.defs")))
                         (replace 'check
-                          (lambda _
-                            (invoke "./praat" "--run"
-                                    "test/runAllTests_batch.praat")))
+                          (lambda* (#:key tests? #:allow-other-keys)
+                            (when tests?
+                              (invoke "./praat" "--run"
+                                      "test/runAllTests_batch.praat"))))
                         (replace 'install
                           (lambda* (#:key outputs #:allow-other-keys)
                             (let* ((out (assoc-ref outputs "out"))