summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-24 16:20:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-24 16:20:51 +0200
commitf45bb3cc0fc4e687f966a8f2fabce73e0c6f31f7 (patch)
tree083dd111609dd5de20026c03b958e4986bc4db8f
parent084e14cc37d893703b526d8f8f9220f7ee3aa0b3 (diff)
downloadguix-f45bb3cc0fc4e687f966a8f2fabce73e0c6f31f7.tar.gz
gnu: Add python-pyfxa.
* gnu/packages/python-web.scm (python-pyfxa): New variable.
-rw-r--r--gnu/packages/python-web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 68a0d78db5..6df33fe41d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2694,3 +2694,34 @@ a simple HTTP request-signing scheme.")
      "This is a Python client library for the BrowserID protocol that
 underlies Mozilla Persona.")
     (license license:mpl2.0)))
+
+(define-public python-pyfxa
+  (package
+    (name "python-pyfxa")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "PyFxA" version))
+       (sha256
+        (base32
+         "0axl16fyrz2r88gnw4b12mk7dpkqscv8c4wsc1y5hicl7bsbc4fm"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f)) ; 17 tests require network access
+    (propagated-inputs
+     `(("python-cryptography" ,python-cryptography)
+       ("python-hawkauthlib" ,python-hawkauthlib)
+       ("python-pybrowserid" ,python-pybrowserid)
+       ("python-requests" ,python-requests)
+       ("python-six" ,python-six)))
+    (native-inputs
+     `(("python-grequests" ,python-grequests)
+       ("python-mock" ,python-mock)
+       ("python-responses" ,python-responses)
+       ("python-unittest2" ,python-unittest2)))
+    (home-page "https://github.com/mozilla/PyFxA")
+    (synopsis "Firefox Accounts client library for Python")
+    (description
+     "This is a Python library for interacting with the Firefox Accounts
+ecosystem.")
+    (license license:mpl2.0)))