summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-23 00:53:39 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-23 00:53:39 -0500
commitf6bf4b2c85ea148e735ffa34139dfbdc4edf37e8 (patch)
tree03e8fb88985013443dc46e760fbed952e7997ba4
parentf9ec89f444906371dc058f202182b670e1ee4785 (diff)
downloadguix-f6bf4b2c85ea148e735ffa34139dfbdc4edf37e8.tar.gz
gnu: Add guile-semver.
* gnu/packages/guile-xyz.scm (guile-semver): New variable.
-rw-r--r--gnu/packages/guile-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 558fa4c1b4..245eb9c0d6 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2689,3 +2689,27 @@ anything other than straight complex DFTs.")
 run SRFI 64 test suites.  It gives Automake insight into the individual
 tests being run, resulting clearer and more specific output.")
     (license license:gpl3+)))
+
+(define-public guile-semver
+  (package
+    (name "guile-semver")
+    (version "0.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://files.ngyro.com/guile-semver/"
+                                  "guile-semver-" version ".tar.gz"))
+              (sha256
+               (base32
+                "06b66rj7nyhr6i3dpkwvfw1xb10w2pngrsw2hxfxkznwsbh9byfz"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("srfi-64-driver" ,srfi-64-driver)))
+    (inputs
+     `(("guile" ,guile-2.2)))
+    (home-page "https://ngyro.com/software/guile-semver.html")
+    (synopsis "Semantic Versioning (SemVer) for Guile")
+    (description "This Guile library provides tools for reading,
+comparing, and writing Semantic Versions.  It also includes ranges in
+the style of the Node Package Manager (NPM).")
+    (license license:gpl3+)))