summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 14:31:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:51 +0200
commitf8c6ab42eff5b16fc9c7469af2762ad449ec6d87 (patch)
tree42e934f507ecdd836707bc918a2b496d10f75fa5
parent18b844e42a1b0e44c42609ede91842e22203321a (diff)
downloadguix-f8c6ab42eff5b16fc9c7469af2762ad449ec6d87.tar.gz
gnu: Add texlive-mathalpha.
* gnu/packages/tex.scm (texlive-mathalpha): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 74d9d2022e..f768299021 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12831,6 +12831,28 @@ Mathématiques Appliquées et Industrielles (SMAI).")
 4th edition.")
     (license license:public-domain)))
 
+(define-public texlive-mathalpha
+  (package
+    (name "texlive-mathalpha")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/mathalpha/"
+                   "tex/latex/mathalpha/")
+             (base32
+              "19wniyaba8cz4vk279ashg68bxq9178cvvz53cng2cn6i6rw32rv")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/mathalpha")
+    (synopsis "General package for loading maths alphabets in LaTeX")
+    (description
+     "Package @code{mathalfa} was renamed to @code{mathalpha}.  For backward
+compatibility the old name will continue to be recognized in LaTeX documents.
+The package provides means of loading maths alphabets (such as are normally
+addressed via macros @code{\\mathcal}, @code{\\mathbb}, @code{\\mathfrak} and
+@code{\\mathscr}).")
+    (license license:lppl1.3c)))
+
 (define-public texlive-mathcommand
   (package
     (name "texlive-mathcommand")