summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-30 19:41:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-30 20:22:59 +0200
commit1839768ca1cf3c52424fb0f8f28f782476535d5f (patch)
tree1938d56ee26386ebb7c2e0676b30ef894b851830
parent684f97f8c903b1133658943c7f6c0e1eb4f1b3de (diff)
downloadguix-1839768ca1cf3c52424fb0f8f28f782476535d5f.tar.gz
gnu: vinagre: Don't build icon-cache.
* gnu/packages/gnome.scm (vinagre)[arguments]: Add custom phase to
remove 'gtk-update-icon-cache'.
[native-inputs]: Remove gtk+-bin.
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2331b33f71..5dcf9b1f5f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2230,6 +2230,12 @@ selection and URL hints.")))
     (arguments
      '(#:phases
        (modify-phases %standard-phases
+         (add-before 'install 'skip-gtk-update-icon-cache
+           (lambda _
+             ;; Don't create 'icon-theme.cache'
+             (substitute* (find-files "." "^Makefile$")
+               (("gtk-update-icon-cache") (which "true")))
+             #t))
          (add-after 'unpack 'patch-configure
            (lambda _
              (substitute* "configure"
@@ -2239,8 +2245,7 @@ selection and URL hints.")))
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)
        ("itstool" ,itstool)
-       ("glib-bin" ,glib "bin")                   ;for glib-compile-schemas
-       ("gtk+-bin" ,gtk+ "bin")))                 ;for gtk-update-icon-cache
+       ("glib-bin" ,glib "bin")))                 ;for glib-compile-schemas
     (inputs
      `(("libxml2" ,libxml2)
        ("gtk-vnc" ,gtk-vnc)