summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-19 23:11:49 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-04-26 21:08:58 +0200
commit1cc3e26b6aeb4acd406b7f57a436bf4c4b35aa93 (patch)
tree128d3f9bad79073d554b09cce580880e4dcf296b
parentd2caedf08d24d6780beede84c0a58f851ee5816c (diff)
downloadguix-1cc3e26b6aeb4acd406b7f57a436bf4c4b35aa93.tar.gz
gnu: fio: Use INVOKE.
* gnu/packages/benchmark.scm (fio)[arguments]: Substitute INVOKE for
SYSTEM* and end phase with explicit #t.
-rw-r--r--gnu/packages/benchmark.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index bf88bd4919..ebc8bdb5f2 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -67,8 +67,9 @@
              ;; The configure script doesn't understand some of the
              ;; GNU options, so we can't use #:configure-flags.
              (let ((out (assoc-ref outputs "out")))
-               (zero? (system* "./configure"
-                               (string-append "--prefix=" out))))))
+               (invoke "./configure"
+                       (string-append "--prefix=" out))
+               #t)))
          ;; The main `fio` executable is fairly small and self contained.
          ;; Moving the auxiliary python and gnuplot scripts to a separate
          ;; output saves almost 400 MiB on the closure.