summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 18:39:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:39:22 +0100
commit204ad455ecb97f27e2e9ed6bd550b1a98e4a1839 (patch)
tree921e625d6adf5104180cd58690f4e1e027ff9d24
parentcbeee88181b6e7d0c102c361bfaf5d1c152e8463 (diff)
downloadguix-204ad455ecb97f27e2e9ed6bd550b1a98e4a1839.tar.gz
gnu: python2-larch: Use INVOKE.
* gnu/packages/python-xyz.scm (python2-larch)[arguments]: Unconditionally
return #T from "check" phase.
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1b138f31b9..6148696c6a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11324,8 +11324,7 @@ happens using the @code{logging} library.")
          ;; and fails.
          (delete 'check)
          (add-before 'build 'check
-           (lambda _
-             (zero? (system* "make" "check")))))))
+           (lambda _ (invoke "make" "check"))))))
     (native-inputs
      `(("cmdtest" ,cmdtest)
        ("python2-coverage-test-runner" ,python2-coverage-test-runner)))