summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-09 15:54:55 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-11 16:35:52 +0100
commit46b082f97f73cd79b40bde15cfe3e4ddb28ba209 (patch)
treeb008756b14819dd4a7077a30b34f471a7930f285
parent5a26f879c3f2f417f594171d909acc3f8227a99c (diff)
downloadguix-46b082f97f73cd79b40bde15cfe3e4ddb28ba209.tar.gz
gnu: kinit: Use KDEINIT5_LIBRARY_PATH to search for dynlibs.
Using LIBRARY_PATH was introduced in
16b8aff85bcdb9799496c4a27257210cd45158e5, but is wrong since
this variable is used by the compiler (gcc) at link time.

* gnu/packages/patches/kinit-kdeinit-libpath.patch: Change
  LIBRARY_PATH to KDEINIT5_LIBRARY_PATH.
* gnu/packages/kde-frameworks.scm (kinit)[native-search-paths]:
  New field.
-rw-r--r--gnu/packages/kde-frameworks.scm4
-rw-r--r--gnu/packages/patches/kinit-kdeinit-libpath.patch2
2 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 0d14c8f887..fff98bd16d 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2556,6 +2556,10 @@ in applications using the KDE Frameworks.")
                (("GUIX_PKGS_KF5_PARTS") (assoc-ref inputs "kparts"))
                (("GUIX_PKGS_KF5_PLASMA") (assoc-ref inputs "plasma-framework")))
              #t)))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "KDEINIT5_LIBRARY_PATH")
+            (files '("lib/")))))
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/patches/kinit-kdeinit-libpath.patch b/gnu/packages/patches/kinit-kdeinit-libpath.patch
index 89cf1a941d..6382e8804b 100644
--- a/gnu/packages/patches/kinit-kdeinit-libpath.patch
+++ b/gnu/packages/patches/kinit-kdeinit-libpath.patch
@@ -23,7 +23,7 @@ pkgs/development/libraries/kde-frameworks/kinit/kinit-libpath.patch
 -                    l.load();
 -                }
 +                // Try to load the library relative to the active profiles.
-+                QByteArrayList profiles = qgetenv("LIBRARY_PATH").split(':');
++                QByteArrayList profiles = qgetenv("KDEINIT5_LIBRARY_PATH").split(':');
 +                for (const QByteArray &profile: profiles) {
 +                    if (!profile.isEmpty()) {
 +                        l.setFileName(QFile::decodeName(profile) + QStringLiteral("/") + libpath);