summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 12:23:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:19 +0100
commit4c523c45353095d389f1093725069a6475c4f1b3 (patch)
tree2475998723d5fb54cb1aa321ba9058ce84614e09
parent9a425d68d44fecc91ebb3fc2bed3bdda1f134482 (diff)
downloadguix-4c523c45353095d389f1093725069a6475c4f1b3.tar.gz
gnu: python-lirc: Update to 1.2.1-2.c28708b.
* gnu/packages/lirc.scm (python-lirc, python2-lirc): Update to
1.2.1-2.c28708b.
[arguments]: Use INVOKE.
-rw-r--r--gnu/packages/lirc.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/lirc.scm b/gnu/packages/lirc.scm
index b04cc887fb..627c79f979 100644
--- a/gnu/packages/lirc.scm
+++ b/gnu/packages/lirc.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
+;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -104,33 +105,32 @@ on just one button press.")
     (license license:gpl2+)))
 
 (define-public python-lirc
-  (let ((commit "4091fe918f3eed2513dad008828565cace408d2f")
-        (revision "1"))
+  (let ((commit "c28708bbeb6e02d85f13dd7e0b24e8e86abc215b")
+        (revision "2"))
     (package
       (name "python-lirc")
-      (version (string-append "1.2.1-" revision "." (string-take commit 7)))
+      (version (git-version "1.2.1" revision commit))
       (source
-        (origin
-          (method git-fetch)
-          (uri (git-reference
-                 (url "https://github.com/tompreston/python-lirc.git")
-                 (commit commit)))
-          (sha256
-            (base32
-              "0cm47s5pvijfs3v2k7hmpxv3mvp4n5la0ihnsczk5ym3iq166jil"))
-          (file-name (string-append name "-" version))))
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/tompreston/python-lirc.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "13s9zqyfh871ls1aha47rhmk13b4mcyfckcn2sw70bvc26832gk6"))))
       (build-system python-build-system)
       (inputs
        `(("lirc" ,lirc)))
       (native-inputs
        `(("python-cython" ,python-cython)))
       (arguments
-       `(#:tests? #f ; the only tests that exist are human-interactive
+       `(#:tests? #f         ; the only tests that exist are interactive
          #:phases
          (modify-phases %standard-phases
            (add-before 'build 'build-from-cython-files
-             (lambda _
-               (zero? (system* "make" "py3")))))))
+             (lambda _ (invoke "make" "py3"))))))
       (home-page "https://github.com/tompreston/python-lirc")
       (synopsis "Python bindings for LIRC")
       (description "@code{lirc} is a Python module which provides LIRC bindings.")
@@ -146,7 +146,6 @@ on just one button press.")
            #:phases
            (modify-phases %standard-phases
              (add-before 'build 'build-from-cython-files
-               (lambda _
-                 (zero? (system* "make" "py2")))))))
+               (lambda _ (invoke "make" "py2"))))))
         (native-inputs
          `(("python2-cython" ,python2-cython))))))