summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 18:39:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:39:56 +0100
commit77e61e25c21de9c262b617e4978c7dd8c0179145 (patch)
tree4fdc44082c7155961274c83cd377775b143f686f
parentac599a0999653ccdae4f070e27ea4a11dafa5e98 (diff)
downloadguix-77e61e25c21de9c262b617e4978c7dd8c0179145.tar.gz
gnu: python2-scientific: Use INVOKE.
* gnu/packages/python-xyz.scm (python2-scientific)[arguments]: Unconditionally
return #T from "build" phase.
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3d3901f8ae..2294b59f33 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13184,9 +13184,9 @@ is the new Pyro version that is actively developed.")
        (modify-phases %standard-phases
          (replace 'build
            (lambda* (#:key inputs #:allow-other-keys)
-             (zero? (system* "python" "setup.py" "build"
-                             (string-append "--netcdf_prefix="
-                                            (assoc-ref inputs "netcdf")))))))))
+             (invoke "python" "setup.py" "build"
+                     (string-append "--netcdf_prefix="
+                                    (assoc-ref inputs "netcdf"))))))))
     (home-page "https://bitbucket.org/khinsen/scientificpython")
     (synopsis "Python modules for scientific computing")
     (description "ScientificPython is a collection of Python modules that are