summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 14:24:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 15:17:47 +0100
commit78854b3849a32b4d4ce44c5a9ba0b607db06a829 (patch)
tree0f684f0cfa2b26bcda201487e2b284ecc45fa183
parent3af27088813cfb09ac2d7d9b216a4e0ac2f1cee7 (diff)
downloadguix-78854b3849a32b4d4ce44c5a9ba0b607db06a829.tar.gz
gnu: jimtcl: Use INVOKE.
* gnu/packages/embedded.scm (jimtcl)[arguments]: Use INVOKE.
-rw-r--r--gnu/packages/embedded.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index f20d1e17c7..004d082470 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -348,8 +348,8 @@ SEGGER J-Link and compatible devices.")
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
-               (zero? (system* "./configure"
-                               (string-append "--prefix=" out)))))))))
+               (invoke "./configure"
+                       (string-append "--prefix=" out))))))))
     (home-page "http://jim.tcl.tk")
     (synopsis "Small footprint Tcl implementation")
     (description "Jim is a small footprint implementation of the Tcl programming