summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-29 20:23:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-29 20:26:45 +0200
commit9123c420ddb420ccfb72d03feb76250f54374f9e (patch)
tree87043a9be13d4bc1f00e5da11741f4718e466360
parent597f35e6f02eccdb4a010472940f642183ed2325 (diff)
downloadguix-9123c420ddb420ccfb72d03feb76250f54374f9e.tar.gz
gnu: vim: Update to 8.1.0644.
* gnu/packages/vim.scm (vim): Update to 8.1.0644.
[native-inputs]: Add libtool.
(xxd)[native-inputs]: New field, empty list.
(vim-full)[native-inputs]: Also inherit native-inputs from vim.
-rw-r--r--gnu/packages/vim.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 6cfdb694ef..53d028681d 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -33,6 +33,7 @@
   #:use-module (gnu packages acl)
   #:use-module (gnu packages admin) ; For GNU hostname
   #:use-module (gnu packages attr)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages gawk)
@@ -61,7 +62,7 @@
 (define-public vim
   (package
     (name "vim")
-    (version "8.1.0551")
+    (version "8.1.0644")
     (source (origin
              (method git-fetch)
              (uri (git-reference
@@ -70,7 +71,7 @@
              (file-name (git-file-name name version))
              (sha256
               (base32
-               "1db5ihzj9flz62alb3kd1w173chb5vbni325abqjf25aly7c22n0"))))
+               "1xksb2v8rw1zgrd5fwqvrh44lf277k85sad2y4ia1z17y7i8j2fl"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
@@ -104,6 +105,8 @@
        ("ncurses" ,ncurses)
        ("perl" ,perl)
        ("tcsh" ,tcsh))) ; For runtime/tools/vim32
+    (native-inputs
+     `(("libtool" ,libtool)))
     (home-page "https://www.vim.org/")
     (synopsis "Text editor based on vi")
     (description
@@ -136,6 +139,7 @@ configuration files.")
                (install-file "xxd" bin)
                #t))))))
     (inputs `())
+    (native-inputs `())
     (synopsis "Hexdump utility from vim")
     (description "This package provides the Hexdump utility xxd that comes
 with the editor vim.")))
@@ -189,7 +193,8 @@ with the editor vim.")))
                                                     display " &")))))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
-       ("xorg-server" ,xorg-server)))
+       ("xorg-server" ,xorg-server)
+       ,@(package-native-inputs vim)))
     (inputs
      `(("acl" ,acl)
        ("atk" ,atk)