summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 11:12:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:39 +0100
commita54b7441266b3c87a3a724518f31af71d190a8ab (patch)
tree27a7b423163f79d7d08a2fb9795a65346cbd6a9e
parent29a26386549f468a69abe1347cd31639524ab949 (diff)
downloadguix-a54b7441266b3c87a3a724518f31af71d190a8ab.tar.gz
gnu: Add ghc-nanospec.
* gnu/packages/haskell-check.scm (ghc-nanospec): New variable.
-rw-r--r--gnu/packages/haskell-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index c7032097b2..8a3b8ad866 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -769,3 +769,27 @@ Haskell, inspired by the Ruby library RSpec.")
     (description "This library provides catchy combinators for HUnit, see
 @uref{https://github.com/sol/hspec-expectations#readme, the README}.")
     (license license:expat)))
+
+(define-public ghc-nanospec
+  (package
+    (name "ghc-nanospec")
+    (version "0.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "nanospec/nanospec-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "1rcmhl9bhyfvanalnf1r86wkx6rq6wdvagnw1h011jcnnb1cq56g"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-hspec" ,ghc-hspec)
+       ("ghc-silently" ,ghc-silently)))
+    (home-page "https://github.com/hspec/nanospec#readme")
+    (synopsis "Lightweight implementation of a subset of Hspec's API")
+    (description
+     "Nanospec is a lightweight implementation of a subset of Hspec's API with
+minimal dependencies.")
+    (license license:expat)))