summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 19:59:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-07 20:26:45 +0100
commitb113f39019913ad8eda4d72624ce9769920d22cb (patch)
tree6ab0168211dfa0eff5ccfdd7ebb24e831608b0d4
parentf09e8abc5e6b115e497d49bdf7e1fb98ebfd8caf (diff)
downloadguix-b113f39019913ad8eda4d72624ce9769920d22cb.tar.gz
gnu: gemma: Fetch sources from git.
* gnu/packages/bioinformatics.scm (gemma)[source]: Fetch from git.
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9f0b8025da..3cd0e03587 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2831,13 +2831,14 @@ comment or quality sections.")
     (name "gemma")
     (version "0.96")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/xiangzhou/GEMMA/archive/v"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/xiangzhou/GEMMA.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "055ynn16gd12pf78n4vr2a9jlwsbwzajpdnf2y2yilg1krfff222"))
+                "0sa4mllp7890v5pss0mm02ik8yixl7az3vprcw3kp7qmr9gwrdai"))
               (patches (search-patches "gemma-intel-compat.patch"))))
     (inputs
      `(("gsl" ,gsl)