summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 20:36:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-07 20:36:07 +0100
commitb8a6230df3fbbeeddb7a0e6976e0b8581bd0ab6e (patch)
treee3992ce8dc1bac248d89f226d558a9c2e7339097
parent57be690d912ad9e1683f80d4de2e1076ae27948d (diff)
downloadguix-b8a6230df3fbbeeddb7a0e6976e0b8581bd0ab6e.tar.gz
gnu: java-htsjdk: Fetch sources from git.
* gnu/packages/bioinformatics.scm (java-htsjdk)[source]: Fetch from git.
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index eae5236cad..28d66a1826 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3117,14 +3117,14 @@ from high-throughput sequencing assays.")
     (name "java-htsjdk")
     (version "2.3.0") ; last version without build dependency on gradle
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/samtools/htsjdk/archive/"
-                    version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/samtools/htsjdk.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1ibhzzxsfc38nqyk9r8zqj6blfc1kh26iirypd4q6n90hs2m6nyq"))
+                "1b178ixcabanm834ydjl3jiakpyxdmki32hqfv2abrzn3rcwa28i"))
               (modules '((guix build utils)))
               (snippet
                ;; Delete pre-built binaries