summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-14 11:10:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:10 +0200
commitb9ff25999d6b3d947ceacd7d01d3b64ac2c8120d (patch)
tree12f9efd16a1d74c002a812117ded58e0ad278ec8
parentf51d8e4cb70cf1be549337e327bcc61253d4eeb3 (diff)
downloadguix-b9ff25999d6b3d947ceacd7d01d3b64ac2c8120d.tar.gz
gnu: Add r-hash.
* gnu/packages/cran.scm (r-hash): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4dd2ec4eae..c36b8b0138 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4766,3 +4766,24 @@ individual SNPs into pre-defined blocks.  A typical application of this new
 approach is the identification of genomic regions, genes, or gene sets
 containing one or more SNPs that evolved under directional selection.")
     (license license:gpl2)))
+
+(define-public r-hash
+  (package
+    (name "r-hash")
+    (version "2.2.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "hash" version))
+       (sha256
+        (base32
+         "0mkx59bmni3b283znvbndnkbar85fzavzdfgmwrhskidsqcz34yz"))))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/web/packages/hash/")
+    (synopsis "Implementation of hash/associated arrays/dictionaries")
+    (description
+     "This package implements a data structure similar to hashes in Perl and
+dictionaries in Python but with a purposefully R flavor.  For objects of
+appreciable size, access using hashes outperforms native named lists and
+vectors.")
+    (license license:gpl2+)))