summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 13:22:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:22:34 +0100
commitbb29e855da30ab9e9b4cbcc7249ee38f26186d0a (patch)
tree77a10d8d869a39a0d6254ed6d97e3e6ce094c0ba
parent20fe9728c4d68f23e4cb34703810dd575cfef767 (diff)
downloadguix-bb29e855da30ab9e9b4cbcc7249ee38f26186d0a.tar.gz
gnu: ocaml-4.02: Use INVOKE.
* gnu/packages/ocaml.scm (ocaml-4.02)[arguments]: Use INVOKE in build phases.
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c9df31ae6a..3731b2aa49 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -191,19 +191,18 @@ patch-/bin/sh-references: ~a: changing `\"/bin/sh\"' to `~a'~%"
                     (mandir (string-append out "/share/man")))
                ;; Custom configure script doesn't recognize
                ;; --prefix=<PREFIX> syntax (with equals sign).
-               (zero? (system* "./configure"
-                               "--prefix" out
-                               "--mandir" mandir)))))
+               (invoke "./configure"
+                       "--prefix" out
+                       "--mandir" mandir))))
          (replace 'build
            (lambda _
-             (zero? (system* "make" "-j" (number->string
-                                          (parallel-job-count))
-                             "world.opt"))))
+             (invoke "make" "-j" (number->string (parallel-job-count))
+                     "world.opt")))
          (delete 'check)
          (add-after 'install 'check
            (lambda _
              (with-directory-excursion "testsuite"
-               (zero? (system* "make" "all")))))
+               (invoke "make" "all"))))
          (add-before 'check 'prepare-socket-test
            (lambda _
              (format (current-error-port)