summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-06-21 09:53:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-06-21 09:55:52 +0300
commitd2885c83929b66a0cf98e740372bddb7e8787631 (patch)
treeb5ff8f32a58a5a71ce1608e6532616582e5ce26c
parentca508f1cfb1c01b0515d1d1c5f04b88fc7e70c8a (diff)
downloadguix-d2885c83929b66a0cf98e740372bddb7e8787631.tar.gz
gnu: cvs-fast-export: Update to 1.43.
* gnu/packages/version-control.scm (cvs-fast-export): Update to 1.43.
[arguments]: Add phases to not build architecture-specific optimized
code and to force python-2. Disable parallel building.
-rw-r--r--gnu/packages/version-control.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 4b78704537..6121a86ab7 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -37,6 +37,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix build utils)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system haskell)
@@ -904,17 +905,29 @@ RCS, PRCS, and Aegis packages.")
 (define-public cvs-fast-export
   (package
     (name "cvs-fast-export")
-    (version "1.33")
+    (version "1.43")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://www.catb.org/~esr/"
                                   name "/" name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1c3s4nacbwlaaccx1fr7hf72kxxrzy49y2rdz5hhqbk8r29vm8w1"))))
+                "17xp5q4cxmd6z0ii1fdr4j1djb9mz1qv7hzr6fawdapjzahi65m3"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases (delete 'configure))
+     '(#:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (add-after 'unpack 'remove-optimizations
+           (lambda _
+             ;; Don't optimize for a specific processor architecture.
+             (substitute* "Makefile"
+               (("CFLAGS \\+= -march=native") ""))
+             ;; This code runs with Python2 or Python3
+             (substitute* "cvsreduce"
+               (("python3") "python"))
+             #t)))
+       #:parallel-build? #f ; parallel a2x commands fail spectacularly
        #:make-flags
        (list "CC=gcc" (string-append "prefix?=" (assoc-ref %outputs "out")))))
     (inputs `(("git" ,git)))