summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 13:23:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:23:27 +0100
commitfa5d6e4c6f0f56d8a909d401f7015f156c20c178 (patch)
tree00eb2a6dc7bba2d7580e9e357d9bbb6e640e2ae9
parentbb29e855da30ab9e9b4cbcc7249ee38f26186d0a (diff)
downloadguix-fa5d6e4c6f0f56d8a909d401f7015f156c20c178.tar.gz
gnu: ocaml-4.01: Use INVOKE.
* gnu/packages/ocaml.scm (ocaml-4.01)[arguments]: Use INVOKE in build phases.
-rw-r--r--gnu/packages/ocaml.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3731b2aa49..cf6580e961 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -12,6 +12,7 @@
 ;;; Copyright © 2018 Peter Kreye <kreyepr@gmail.com>
 ;;; Copyright © 2018, 2019 Gabriel Hondet <gabrielhondet@gmail.com>
 ;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -253,7 +254,7 @@ functional, imperative and object-oriented styles of programming.")
            (replace 'build
              (lambda _
                ;; Specifying '-j' at all causes the build to fail.
-               (zero? (system* "make" "world.opt"))))
+               (invoke "make" "world.opt")))
            ,@(if (string=? "aarch64-linux" (%current-system))
                ;; Custom configure script doesn't recongnize aarch64.
                '((replace 'configure
@@ -268,11 +269,9 @@ functional, imperative and object-oriented styles of programming.")
            (replace 'check
              (lambda _
                (with-directory-excursion "testsuite"
-                 (zero? (system*
-                         "make"
-                         "all"
+                 (invoke "make" "all"
                          (string-append
-                          "TOPDIR=" (getcwd) "/.."))))))))))))
+                          "TOPDIR=" (getcwd) "/..")))))))))))
 
 (define-public ocaml-4.07
   (package