summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-03-09 15:19:50 -0500
committerLeo Famulari <leo@famulari.name>2016-03-09 15:19:50 -0500
commit89e58e8e8c941b74f2280f40a1204ba97fd9a323 (patch)
treea151b9d238dc5dc20edbb3e9cac760426004cbd6
parent6da23c042985ddd2a55698d257299f26c64808b9 (diff)
downloadguix-89e58e8e8c941b74f2280f40a1204ba97fd9a323.tar.gz
libotr: Update to 4.1.1 [fixes CVE-2016-2851].
* gnu/packages/messaging.scm (libotr): Update to 4.1.1.
[native-inputs]: New field.
-rw-r--r--gnu/packages/messaging.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 076c4dcdc6..6e1c474876 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -63,17 +63,19 @@
 (define-public libotr
   (package
     (name "libotr")
-    (version "4.1.0")
+    (version "4.1.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://otr.cypherpunks.ca/libotr-"
                                   version ".tar.gz"))
               (sha256
-               (base32 "0c6rkh58s6wqzcrpccwdik5qs91qj6dgd60a340d72gc80cqknsg"))))
+               (base32
+                "1x8rliydhbibmzwdbyr7pd7n87m2jmxnqkpvaalnf4154hj1hfwb"))))
     (build-system gnu-build-system)
     (propagated-inputs
      `(("libgcrypt" ,libgcrypt)))  ; libotr headers include gcrypt.h
     (inputs `(("libgpg-error" ,libgpg-error)))
+    (native-inputs `(("perl" ,perl))) ; for the test suite
     (synopsis "Off-the-Record (OTR) Messaging Library and Toolkit")
     (description
      "OTR allows you to have private conversations over instant messaging by