summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-30 00:03:10 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-30 00:03:10 +0800
commitb416c647e934c1a086a3cb534d31968e7ea53808 (patch)
treeade5b1f4da02a991bb6a52290b477d1b55357c71
parente32316e62f54bbda07e88f22d97fc28b84eb70b8 (diff)
downloadguix-b416c647e934c1a086a3cb534d31968e7ea53808.tar.gz
gnu: jack2: Add $libdir to the RUNPATH of all the binaries.
* gnu/packages/audio.scm (jack2)[arguments]: Add #:phases.
-rw-r--r--gnu/packages/audio.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 06f8bbdbea..593d47d7a1 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -520,7 +520,18 @@ synchronous execution of all clients, and low latency operation.")
     (arguments
      `(#:tests? #f  ; no check target
        #:configure-flags '("--dbus"
-                           "--alsa")))
+                           "--alsa")
+       #:phases
+       (modify-phases %standard-phases
+         (add-before
+          'configure 'set-linkflags
+          (lambda _
+            ;; Add $libdir to the RUNPATH of all the binaries.
+            (substitute* "wscript"
+              ((".*CFLAGS.*-Wall.*" m)
+               (string-append m
+                              "    conf.env.append_unique('LINKFLAGS',"
+                              "'-Wl,-rpath=" %output "/lib')\n"))))))))
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("dbus" ,dbus)