summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-07-27 05:28:34 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-29 17:29:50 +0200
commit2614de3c5a92bc9ec98d173455185c088315fdb6 (patch)
tree384ed42ae01a06579ea2ecce7f257620c9c994b9
parentba9e2ee64a566d3bdaa93423a56d1fd613cef5f3 (diff)
downloadguix-2614de3c5a92bc9ec98d173455185c088315fdb6.tar.gz
gnu: Add stellarium.
* gnu/local.mk: Include gnu/packages/education.scm .
* gnu/packages/education.scm: Add new file.
* gnu/packages/education.scm (stellarium): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/education.scm69
2 files changed, 70 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index c789b191d8..e5374d501c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -103,6 +103,7 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/dvtm.scm				\
   %D%/packages/ebook.scm			\
   %D%/packages/ed.scm				\
+  %D%/packages/education.scm			\
   %D%/packages/elf.scm				\
   %D%/packages/emacs.scm			\
   %D%/packages/enchant.scm			\
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
new file mode 100644
index 0000000000..834cd6baf6
--- /dev/null
+++ b/gnu/packages/education.scm
@@ -0,0 +1,69 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages education)
+  #:use-module (ice-9 regex)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages qt)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages gettext)
+  #:use-module (gnu packages perl)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix svn-download)
+  #:use-module (guix utils)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix build-system cmake)
+  #:use-module (srfi srfi-1))
+
+(define-public stellarium
+  (package
+    (name "stellarium")
+    (version "0.14.2")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://sourceforge/stellarium/"
+                                 "Stellarium-sources/"
+                                 version "/stellarium-" version ".tar.gz"))
+             (sha256 (base32
+                      "1xxil0rv61zc08znfv83cpsc47y1gjl2f3njhz0pn5zd8jpaa15a"))))
+    (build-system cmake-build-system)
+    (inputs
+      `(("qtbase" ,qtbase)
+        ("zlib" ,zlib)
+        ("qtserialport" ,qtserialport)
+        ("qtscript" ,qtscript)
+        ("gettext" ,gnu-gettext)))
+    (native-inputs
+      `(("qtbase" ,qtbase)                   ;Qt MOC is needed at compile time
+        ("qttools" ,qttools)
+        ("perl" ,perl)))                          ;for 'pod2man'
+    (arguments
+      `(#:test-target "tests"
+        #:phases (modify-phases %standard-phases
+                   (add-before 'check 'set-offscreen-display
+                     (lambda _
+                       (setenv "QT_QPA_PLATFORM" "offscreen")
+                       (setenv "HOME" "/tmp")
+                       #t)))))
+    (home-page "http://www.stellarium.org/")
+    (synopsis "3D sky viewer")
+    (description "Stellarium is a planetarium.  It shows a realistic sky in
+3D, just like what you see with the naked eye, binoculars, or a telescope.")
+    (license license:gpl2+)))