summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-04-16 14:05:00 +0200
committerLudovic Courtès <ludo@gnu.org>2013-04-16 14:05:00 +0200
commit35ac56b63e438aaefde9364db7164dd213677022 (patch)
treea3e3fdf6abdff1740a4801b987a2c212c928469c
parent50efa797742af747f8d544a4fac52116993d9da8 (diff)
downloadguix-35ac56b63e438aaefde9364db7164dd213677022.tar.gz
build-system/{perl,cmake}: Keep the standard search paths of gnu-build-system.
Reported by Andreas Enge <andreas@enge.fr>.

* guix/build-system/gnu.scm (standard-search-paths): New procedure.
  (gnu-build): Use it.
* guix/build-system/perl.scm (perl-build):
  Append (standard-search-paths) to the search paths of PERL.
* guix/build-system/cmake.scm (cmake-build):
  Append (standard-search-paths) to SEARCH-PATHS.
-rw-r--r--guix/build-system/cmake.scm3
-rw-r--r--guix/build-system/gnu.scm18
-rw-r--r--guix/build-system/perl.scm3
3 files changed, 16 insertions, 8 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index 4e993f3961..3347dc502c 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -72,7 +72,8 @@ provides a 'CMakeLists.txt' file as its build system."
                     #:outputs %outputs
                     #:inputs %build-inputs
                     #:search-paths ',(map search-path-specification->sexp
-                                          search-paths)
+                                          (append search-paths
+                                                  (standard-search-paths)))
                     #:patches ,patches
                     #:patch-flags ,patch-flags
                     #:phases ,phases
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index 3b3d99b313..b64bce7dae 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -27,6 +27,7 @@
   #:use-module (ice-9 match)
   #:export (gnu-build
             gnu-build-system
+            standard-search-paths
             standard-inputs
             package-with-explicit-inputs
             package-with-extra-configure-variable
@@ -143,6 +144,16 @@ standard packages used as implicit inputs of the GNU build system."
   (let ((distro (resolve-module '(gnu packages base))))
     (module-ref distro '%final-inputs)))
 
+(define (standard-search-paths)
+  "Return the list of <search-path-specification> for the standard (implicit)
+inputs."
+  (append-map (match-lambda
+               ((_ (? package? p) _ ...)
+                (package-native-search-paths p))
+               (_
+                '()))
+              (standard-packages)))
+
 (define standard-inputs
   (memoize
    (lambda (system)
@@ -204,12 +215,7 @@ which could lead to gratuitous input divergence."
 
   (define implicit-search-paths
     (if implicit-inputs?
-        (append-map (match-lambda
-                     ((_ (? package? p) _ ...)
-                      (package-native-search-paths p))
-                     (_
-                      '()))
-                    (standard-packages))
+        (standard-search-paths)
         '()))
 
   (define builder
diff --git a/guix/build-system/perl.scm b/guix/build-system/perl.scm
index c97698e225..1ff9fd2674 100644
--- a/guix/build-system/perl.scm
+++ b/guix/build-system/perl.scm
@@ -55,7 +55,8 @@
   "Build SOURCE using PERL, and with INPUTS.  This assumes that SOURCE
 provides a `Makefile.PL' file as its build system."
   (define perl-search-paths
-    (package-native-search-paths perl))
+    (append (package-native-search-paths perl)
+            (standard-search-paths)))
 
   (define builder
     `(begin