summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-26 17:23:56 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-26 17:23:56 +0200
commit5708485357ef0e55f5148347958c4fe9a860453e (patch)
tree4bb8599e66f30bd392190c2cb6379a24dc82f8b6
parent11acdf1747a18fe11ccbabb78b5b14884164ee39 (diff)
downloadguix-5708485357ef0e55f5148347958c4fe9a860453e.tar.gz
gnu: make-bootstrap: Fix cross compilation of binutils-static.
* gnu/packages/make-bootstrap.scm (%binutils-static): Inherit configure
  flags from BINUTILS.
-rw-r--r--gnu/packages/make-bootstrap.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 853dc8e59d..f4d29bdf96 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -260,7 +260,11 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
   (package (inherit binutils)
     (name "binutils-static")
     (arguments
-     `(#:configure-flags '("--disable-gold" "--with-lib-path=/no-ld-lib-path")
+     `(#:configure-flags (cons "--disable-gold"
+                               ,(match (memq #:configure-flags
+                                             (package-arguments binutils))
+                                  ((#:configure-flags flags _ ...)
+                                   flags)))
        #:strip-flags '("--strip-all")
        #:phases (alist-cons-before
                  'configure 'all-static