summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-26 23:09:35 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-26 23:09:35 +0100
commit6170834d47e4d3b2f1373053eba2a6b136a9875b (patch)
tree33abda36ec152488f2bf17a8b1ae5a782c14a4e5
parent12b0dbd472d1020565b2d1e3f4c72fca635db0a8 (diff)
downloadguix-6170834d47e4d3b2f1373053eba2a6b136a9875b.tar.gz
gnu: glibc: Fix cross-compilation regression.
Fixes a regression introduced in 12b0dbd.
See <http://lists.gnu.org/archive/html/guix-devel/2015-03/msg00698.html>.

* gnu/packages/base.scm (glibc)[arguments] <pre-configure>: Add
  #:native-inputs parameter.  Look up "static-bash" first in INPUTS,
  then in NATIVE-INPUTS.
-rw-r--r--gnu/packages/base.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 69d1205259..94a93a245d 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -431,7 +431,8 @@ included.")
       #:tests? #f                                 ; XXX
       #:phases (alist-cons-before
                 'configure 'pre-configure
-                (lambda* (#:key inputs outputs #:allow-other-keys)
+                (lambda* (#:key inputs native-inputs outputs
+                          #:allow-other-keys)
                   (let* ((out  (assoc-ref outputs "out"))
                          (bin  (string-append out "/bin")))
                     ;; Use `pwd', not `/bin/pwd'.
@@ -455,8 +456,13 @@ included.")
 
                     ;; Copy a statically-linked Bash in the output, with
                     ;; no references to other store paths.
+                    ;; FIXME: Normally we would look it up only in INPUTS but
+                    ;; cross-base uses it as a native input.
                     (mkdir-p bin)
-                    (copy-file (string-append (assoc-ref inputs "static-bash")
+                    (copy-file (string-append (or (assoc-ref inputs
+                                                             "static-bash")
+                                                  (assoc-ref native-inputs
+                                                             "static-bash"))
                                               "/bin/bash")
                                (string-append bin "/bash"))
                     (remove-store-references (string-append bin "/bash"))