summary refs log tree commit diff
diff options
context:
space:
mode:
authorrain1 <rain1@openmailbox.org>2016-03-24 16:24:03 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-04-03 19:39:40 +0300
commitc5e1fcd0aea87e841a8484ce28679d11d602f137 (patch)
tree13120b48be733427b7ed0540f98f284d9422f8a0
parent3cf0dbda97497be4f058c269b0f49132d15fbea1 (diff)
downloadguix-c5e1fcd0aea87e841a8484ce28679d11d602f137.tar.gz
gnu: ffmpeg: Update to 3.0.0.
* gnu/packages/video.scm (ffmpeg): Update to 3.0.0.
[inputs]: Remove libquvi.
[arguments]: Remove '--enable-libquvi" configure flag, rename mipsdspri1
flag to mipsdsp.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/video.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index a870dd8ee1..494889a14b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -372,14 +372,14 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
 (define-public ffmpeg
   (package
     (name "ffmpeg")
-    (version "2.8.6")
+    (version "3.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1yh7dvm7zwdlsspdaq524s5qaggma5md9h95qc4kvb5dmyyyvg15"))))
+               "0w74b165l4ry4y72f4xmgd357pvbc7yr61y313v3ai6787p2rwqj"))))
     (build-system gnu-build-system)
     (inputs
      `(("fontconfig" ,fontconfig)
@@ -392,7 +392,6 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
        ("libbluray" ,libbluray)
        ("libcaca" ,libcaca)
        ("libcdio-paranoia" ,libcdio-paranoia)
-       ("libquvi" ,libquvi)
        ("libtheora" ,libtheora)
        ("libvdpau" ,libvdpau)
        ("libvorbis" ,libvorbis)
@@ -480,7 +479,6 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
          "--enable-libmp3lame"
          "--enable-libopus"
          "--enable-libpulse"
-         "--enable-libquvi"
          "--enable-libsoxr"
          "--enable-libspeex"
          "--enable-libtheora"
@@ -498,7 +496,7 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
          ;; Runtime cpu detection is not implemented on
          ;; MIPS, so we disable some features.
          "--disable-mips32r2"
-         "--disable-mipsdspr1"
+         "--disable-mipsdsp"
          "--disable-mipsdspr2"
          "--disable-mipsfpu")
        #:phases