summary refs log tree commit diff
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2016-07-28 19:06:10 -0500
committerMathieu Lirzin <mthl@gnu.org>2016-07-29 11:00:31 +0200
commit61201e46a72b715e1a38ce56932c3f4f2d3885b4 (patch)
tree22c06758851d05518edc21b38a9b6f55979b6858
parentf33e71fca2105c2110a00a12acdce7d88d544d16 (diff)
downloadguix-61201e46a72b715e1a38ce56932c3f4f2d3885b4.tar.gz
gnu: password-store: Wrap PATH.
* gnu/packages/password-utils.scm (password-store)
[arguments]: Wrap PATH more thoroughly.
[native-inputs]: Move getopt to inputs.
[inputs]: Add sed.

Signed-off-by: Mathieu Lirzin <mthl@gnu.org>
-rw-r--r--gnu/packages/password-utils.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index a03214ae6d..7a8bdcb5f3 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2016 Jessica Tallon <tsyesika@tsyesika.se>
 ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
+;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -266,27 +267,26 @@ any X11 window.")
      '(#:phases
        (modify-phases %standard-phases
          (delete 'configure)
-         (add-after
-          ;; The script requires 'getopt' at run-time, and this allows
-          ;; the user to not install the providing package 'util-linux'
-          ;; in their profile.
-          'unpack 'patch-path
-          (lambda* (#:key inputs outputs #:allow-other-keys)
-            (let ((getopt (string-append (assoc-ref inputs "getopt")
-                                         "/bin/getopt")))
-              (substitute* "src/password-store.sh"
-                (("GETOPT=\"getopt\"")
-                 (string-append "GETOPT=\"" getopt "\"")))
-              #t))))
+         (add-after 'install 'wrap-path
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (path (map (lambda (pkg)
+                                (string-append (assoc-ref inputs pkg) "/bin"))
+                              '("coreutils" "getopt" "git" "gnupg" "pwgen"
+                                "sed" "tree" "which" "xclip"))))
+               (wrap-program (string-append out "/bin/pass")
+                 `("PATH" ":" prefix (,(string-join path ":"))))))))
        #:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
        #:test-target "test"))
-    (native-inputs `(("getopt" ,util-linux))) ; getopt for the tests
-    (inputs `(("gnupg" ,gnupg)
-              ("pwgen" ,pwgen)
-              ("xclip" ,xclip)
-              ("git" ,git)
-              ("tree" ,tree)
-              ("which" ,which)))
+    (inputs
+     `(("getopt" ,util-linux)
+       ("git" ,git)
+       ("gnupg" ,gnupg)
+       ("pwgen" ,pwgen)
+       ("sed" ,sed)
+       ("tree" ,tree)
+       ("which" ,which)
+       ("xclip" ,xclip)))
     (home-page "http://www.passwordstore.org/")
     (synopsis "Encrypted password manager")
     (description "Password-store is a password manager which uses GnuPG to