summary refs log tree commit diff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-07-12 15:59:52 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-08 22:08:17 +1000
commit70f1bc051a5e06e14acde6cfe8fcaace656adbf4 (patch)
tree1b0378ec0ee860fc5129fa7ce3c8868fead2cbd9
parent985d8411446dce13e55f7543de6672150a73eabd (diff)
downloadguix-70f1bc051a5e06e14acde6cfe8fcaace656adbf4.tar.gz
gnu: Add bpp-seq.
* gnu/packages/bioinformatics.scm (bpp-seq): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8b86e52ece..7a6c144e32 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -555,6 +555,40 @@ Bio++ intends to help programmers to write computer expensive programs, by
 providing them a set of re-usable tools.")
       (license license:cecill-c))))
 
+(define-public bpp-seq
+  ;; The last release was in 2014 and the recommended way to install from source
+  ;; is to clone the git repository, so we do this.
+  ;; http://biopp.univ-montp2.fr/wiki/index.php/Main_Page
+  (let ((commit "6cfa07965ce152e5598a89df2fa80a75973bfa33"))
+    (package
+      (name "bpp-seq")
+      (version (string-append "2.2.0-1." (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "http://biopp.univ-montp2.fr/git/bpp-seq")
+                      (commit commit)))
+                (file-name (string-append name "-" version "-checkout"))
+                (sha256
+                 (base32
+                  "1nys5jq7jqvdg40d91wsmj3q2yzy4276cp7sp44n67p468f27zf2"))))
+      (build-system cmake-build-system)
+      (arguments
+       `(#:parallel-build? #f
+         ;; If out-of-source, test data is not copied into the build directory
+         ;; so the tests fail.
+         #:out-of-source? #f))
+      (inputs
+       `(("bpp-core" ,bpp-core)
+         ("gcc" ,gcc-5))) ; Use GCC 5 as per 'bpp-core'.
+      (home-page "http://biopp.univ-montp2.fr")
+      (synopsis "Bio++ sequence library")
+      (description
+       "Bio++ is a set of C++ libraries for Bioinformatics, including sequence
+analysis, phylogenetics, molecular evolution and population genetics.  This
+library provides sequence-related modules.")
+      (license license:cecill-c))))
+
 (define-public blast+
   (package
     (name "blast+")