summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-09 16:05:24 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:23 +0100
commitd548e6aa06702793471ae764bd4df3265dbcfb7f (patch)
tree39b235ec142ca3a4b0f1ad13561a81be89d486b5
parentca33a3ad970db4fa7ede5d977db576ae98e67406 (diff)
downloadguix-d548e6aa06702793471ae764bd4df3265dbcfb7f.tar.gz
gnu: python-scipy: Fix build.
* gnu/packages/python.scm (python-scipy) Use add-installed-pythonpath.  Add
  dummy newlines character to string to make emacs happy.
-rw-r--r--gnu/packages/python.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0c5450bec4..e0d0843839 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3614,7 +3614,9 @@ functions.")
 libraries = openblas
 library_dirs = ~a/lib
 include_dirs = ~a/include
-[atlas]
+
+# backslash-n to make emacs happy
+\n[atlas]
 library_dirs = ~a/lib
 atlas_libs = openblas
 "
@@ -3624,11 +3626,14 @@ atlas_libs = openblas
           #t)
         (alist-cons-after
          'install 'install-doc
-         (lambda* (#:key outputs #:allow-other-keys)
+         (lambda* (#:key inputs outputs #:allow-other-keys)
            (let* ((data (string-append (assoc-ref outputs "doc") "/share"))
                   (doc (string-append data "/doc/" ,name "-" ,version))
                   (html (string-append doc "/html"))
                   (pyver ,(string-append "PYVER=")))
+             ;; Make installed package available for building the
+             ;; documentation
+             (add-installed-pythonpath inputs outputs)
              (with-directory-excursion "doc"
                ;; Fix generation of images for mathematical expressions.
                (substitute* (find-files "source" "conf\\.py")