summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-01 15:06:04 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-02 14:30:14 +0200
commite7c097306dea32cece9b2001ffc9918e1076677f (patch)
treec2351fc7e890d6ad53f5b4d9b72f88bccb5c3a7f
parent132b4c8c235e599a28604facce7ecee01b4a446e (diff)
downloadguix-e7c097306dea32cece9b2001ffc9918e1076677f.tar.gz
gnu: Add HTSlib.
* gnu/packages/bioinformatics.scm (htslib): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f66ea26b2a..c7836f173e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -919,6 +919,41 @@ sequencing (HTS) data.  There are also an number of useful utilities for
 manipulating HTS data.")
     (license license:expat)))
 
+(define-public htslib
+  (package
+    (name "htslib")
+    (version "1.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/samtools/htslib/releases/download/"
+                    version "/htslib-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1c32ssscbnjwfw3dra140fq7riarp2x990qxybh34nr1p5r17nxx"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after
+          'unpack 'patch-tests
+          (lambda _
+            (substitute* "test/test.pl"
+              (("/bin/bash") (which "bash")))
+            #t)))))
+    (inputs
+     `(("zlib" ,zlib)))
+    (native-inputs
+     `(("perl" ,perl)))
+    (home-page "http://www.htslib.org")
+    (synopsis "C library for reading/writing high-throughput sequencing data")
+    (description
+     "HTSlib is a C library for reading/writing high-throughput sequencing
+data.  It also provides the bgzip, htsfile, and tabix utilities.")
+    ;; Files under cram/ are released under the modified BSD license;
+    ;; the rest is released under the Expat license
+    (license (list license:expat license:bsd-3))))
+
 (define-public macs
   (package
     (name "macs")