summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 16:34:56 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:28 -0600
commite8bba431a81872bb16a2497908477dbec1258224 (patch)
tree724cebef6789448972749fc911520c88d3aad593
parentce60f167ea229a4aa2f369534e6330755b970a9f (diff)
downloadguix-e8bba431a81872bb16a2497908477dbec1258224.tar.gz
gnu: Add inc-latest.
* gnu/packages/perl.scm (perl-inc-latest): New variable.
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3b15a2d687..fa25a8d36a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -737,6 +737,26 @@ vaguely inspired by John Ousterhout's Tk_ParseArgv.")
                               "Getopt-Tabular-" version))
     (license (package-license perl))))
 
+(define-public perl-inc-latest
+  (package
+    (name "perl-inc-latest")
+    (version "0.500")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
+                           "inc-latest-" version ".tar.gz"))
+       (sha256
+        (base32
+         "04f6qf6ll2hkdsr9aglykg3wlgsnf0w4f264nzg4i9y6cgrhbafs"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/inc-latest")
+    (synopsis "Use modules in inc/ if newer than installed")
+    (description "The inc::latest module helps bootstrap configure-time
+dependencies for CPAN distributions.  These dependencies get bundled into the
+inc directory within a distribution and are used by Makefile.PL or Build.PL.")
+    (license asl2.0)))
+
 (define-public perl-io-tty
   (package
     (name "perl-io-tty")