summary refs log tree commit diff
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2017-10-26 17:02:30 -0400
committerMarius Bakke <mbakke@fastmail.com>2017-10-27 00:42:06 +0200
commit3414ce98765bb0f58507418bfb9fa68bded06591 (patch)
treefc2e12a2585027e4fb806881f317b6962893a556
parent9d0866ce1b85c3433552627909dd67aba64814f7 (diff)
downloadguix-3414ce98765bb0f58507418bfb9fa68bded06591.tar.gz
gnu: snakemake: Update to 4.2.0.
* gnu/packages/python.scm (snakemake): Update to 4.2.0.
[propagated-inputs]: Add python-appdirs, python-configargparse, python-pyyaml,
and python-ratelimiter, which are dependencies as of Snakemake 4.1.0.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fed7394d78..e8a7339199 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6626,13 +6626,13 @@ of the structure, dynamics, and functions of complex networks.")
 (define-public snakemake
   (package
     (name "snakemake")
-    (version "3.13.3")
+    (version "4.2.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "snakemake" version))
        (sha256
-        (base32 "1nixb944r4hlskwkzc4wjs34b40xpxpw9gmhhm5p09gvmm22ap5d"))))
+        (base32 "0mgl44q152ws40zj2vicqark5szyd73vqy9pf26g6hk6dk0y0c79"))))
     (build-system python-build-system)
     (arguments
      ;; TODO: Package missing test dependencies.
@@ -6651,7 +6651,11 @@ of the structure, dynamics, and functions of complex networks.")
              #t)))))
     (propagated-inputs
      `(("python-wrapt" ,python-wrapt)
-       ("python-requests" ,python-requests)))
+       ("python-requests" ,python-requests)
+       ("python-appdirs" ,python-appdirs)
+       ("python-configargparse" ,python-configargparse)
+       ("python-pyyaml" ,python-pyyaml)
+       ("python-ratelimiter" ,python-ratelimiter)))
     (home-page "https://bitbucket.org/snakemake/snakemake/wiki/Home")
     (synopsis "Python-based execution environment for make-like workflows")
     (description