summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:01 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:56 -0400
commit3b281f5b8d9f7ee26d35c007ca17c1cb228eaa2f (patch)
tree723cbec4d61630efd4008ab5aeda70ad93de9126
parent4fec5cdbf476067a2c2105121139857c024b547e (diff)
downloadguix-3b281f5b8d9f7ee26d35c007ca17c1cb228eaa2f.tar.gz
gnu: Add ghc-process.
* gnu/packages/haskell.scm (ghc-process): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3fb847a4d2..a14163d295 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6930,4 +6930,24 @@ supported.  A module of colour names (\"Data.Colour.Names\") is provided.")
 files and directories in a portable way.")
     (license license:bsd-3)))
 
+(define-public ghc-process
+  (package
+    (name "ghc-process")
+    (version "1.4.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/process/process-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "1v1bav5isqxq9fc4lw714x94qbfsjbm2nn12kjp69r1ql8jaaaqw"))))
+    (build-system haskell-build-system)
+    (home-page "http://hackage.haskell.org/package/process")
+    (synopsis "System process libraries")
+    (description
+     "This package contains libraries for dealing with system processes.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here