summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:02 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:56 -0400
commit6e0741f739fe08ad686b73c1cf90118a2d649905 (patch)
tree2e64422f2b092b9e6207985e9e61caa8b748d579
parent3b281f5b8d9f7ee26d35c007ca17c1cb228eaa2f (diff)
downloadguix-6e0741f739fe08ad686b73c1cf90118a2d649905.tar.gz
gnu: Add ghc-wl-pprint-text.
* gnu/packages/haskell.scm (ghc-wl-pprint-text): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index a14163d295..523fceb31c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6950,4 +6950,26 @@ files and directories in a portable way.")
      "This package contains libraries for dealing with system processes.")
     (license license:bsd-3)))
 
+(define-public ghc-wl-pprint-text
+  (package
+    (name "ghc-wl-pprint-text")
+    (version "1.1.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/wl-pprint-text/wl-pprint-text-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "1xgizzimfw17mpmw2afvmnvyag976j8ggn7k5r564rkw9f0m6bgz"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-text" ,ghc-text)))
+    (home-page "http://hackage.haskell.org/package/wl-pprint-text")
+    (synopsis "Wadler/Leijen Pretty Printer for Text values")
+    (description
+     "A clone of wl-pprint for use with the text library.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here