summary refs log tree commit diff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-04-03 06:53:03 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-04-03 16:08:11 +1000
commit78c0d323e9fae4a5b5a2b3c54eeab5a5677b7804 (patch)
treee1c9675d14f15b045eaf299cc90e710489f19a71
parentfd7575d4790a49509969e5d93767a76cc54eb2ac (diff)
downloadguix-78c0d323e9fae4a5b5a2b3c54eeab5a5677b7804.tar.gz
gnu: python-pandas: Update to 0.18.0.
* gnu/packages/python.scm (python-pandas, python2-pandas): Update to 0.18.0.
[arguments]: Enable tests.
-rw-r--r--gnu/packages/python.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e32022606e..f91980819c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -978,20 +978,14 @@ datetime module, available in Python 2.3+.")
 (define-public python-pandas
   (package
     (name "python-pandas")
-    (version "0.16.2")
+    (version "0.18.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pandas" version))
        (sha256
-        (base32 "10agmrkps8bi5948vwpipfxds5kj1d076m9i0nhaxwqiw7gm6670"))))
+        (base32 "050qw0ap5bhyv5flp78x3lcq1dlminl3xaj6kbrm0jqmx0672xf9"))))
     (build-system python-build-system)
-    (arguments
-     `(;; Three tests fail:
-       ;; - test_read_google
-       ;; - test_read_yahoo
-       ;; - test_month_range_union_tz_dateutil
-       #:tests? #f))
     (propagated-inputs
      `(("python-numpy" ,python-numpy)
        ("python-pytz" ,python-pytz)